Symptom 

The add-in fails to connect to a specific list or library in SharePoint Online. 

Cause 

There are many reasons why this could fail. Please try out the following steps that will help you find your cause. 

Resolution 1 | No access to the SharePoint Root Site 

For any officeatwork 365 add-in to be able to connect to SharePoint in your Office 365 tenant each user that wants to connect needs at least read rights for your root site. Here are some step-by-step instructions on how you can check who has access to your root site in SharePoint. 

  • click on the SharePoint icon on our Office 365 home page (office.com) 

 

  • Change the URL in your Browser by removing everything that comes after sharepoint.com/ and then reload the page. 

  • Click on the gear icon and choose ‘Site settings’ 

 

  • Click on ‘Site Permissions’ 

 

  • Check to see if all the users that need to work with SharePoint data are in one of the groups and have at least ‘read’ permissions.