Symptom

- Menüband ist ausgegraut

- Vorlagen über Tray-Icon können nicht ausgewählt werden

- Dokumente aus SharePoint können ausgeführt werden, aber das Dokument kann nicht abgeschlossen werden



Ursache

Dieses Verhalten wird durch die Installation von Skype for Business verursacht.


Skype for Business ist in Office 2016 integriert. Wenn Sie eine andere Version von Office verwenden und sich entschieden haben, nur Skype for Business zu installieren, wird diese Kombination dieses Verhalten auslösen.


Durch die Installation von Skype for Business wird durch den Schlüssel von Skype for Business ein weiterer Ordner in der Registry angelegt, der auf den Ordner Office 2016 benannt wird. Da Skype for Business eine neue Komponente von Office 2016 ist, wird es im gleichen Ordner in der Registry registriert.


Die Versionen für Office in der Registry sind benannt.

Egal, welchen dieser Schlüssel Sie registriert hatten oder welche Office-Version Sie installiert haben, wenn Sie eine Installation von Skype for Business vornehmen, sehen Sie den neuen Ordner 2.8 in der Registry. Unbenannt1.png


Im Ordner Win32 Ihrer aktuellen Office-Version finden Sie einen Schlüssel, der auf die MSO.DLL verweist, die benötigt wird. Im neu erstellten Ordner durch die Installation von skype for business finden Sie diesen Pfad im Win32-Ordner, der auf die MSO.DLL verweist, nicht. Bei der Verwendung von officeatwork wird dieser Pfad nun benötigt.


Für den Fall, dass officeatwork auf Office aufbaut, müssen Sie bei einer Neuinstallation von Office oder bei einem Update von Office immer officeatwork neu installieren, damit die Schlüssel richtig gesetzt und richtig verbunden sind.  Für den Fall, dass dieser Schlüssel 2.8 nun erstellt wird, wird die Installation von Office (z.B. Word) manipuliert, es wird eine Installation von Word 2016 erwartet, so dass der korrekte Schlüssel nicht in diesem neuen Ordner 2.8 gefunden werden kann.



Lösung

Erstellen Sie den genauen Ordner und die Tasten im neuen Ordner 2.8.


Schritte zur Auflösung:

  1. Suchen Sie in der Registry mit diesem Schlüssel: {000C03A7-0000-0000-C000-000000000046} (Diesen Schlüssel finden Sie in den Logfiles von officeatwork)
    - Dieser Schlüssel sollte sich in Computer\HKEY_CLASSES_ROOT\Wow6432Node\Interface\{000C03A7-0000-0000-C000-000000000046} befinden.
  2. Wenn Sie diesen Ordner öffnen, gibt es einen weiteren Ordner namens "TypeLib". Hier sehen Sie eine Versionsnummer, die Sie bitte notieren. Bitte kopieren Sie den Schlüssel, der in diesem TypeLib-Ordner registriert ist (In meinem Fall {2DF8D04C-5BFA-101B-BDE5-00AA0044DE52}) und gehen Sie eine weitere Suche durch.
  3. Dieser Schlüssel sollte sich nun in "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Classes\TypeLib\{2DF8D04C-5BFA-101B-BDE5-00AA0044DE52}" befinden. (Bitte beachten Sie, dass Sie diesen Schlüssel nicht nur in diesem Pfad finden können)
  4. Öffnen Sie hier den Ordner mit der gleichen Version, die Sie im vorherigen Schritt gesehen haben. Es sollte die Version 2.8 sein.
  5. Erstellen Sie nun in diesem Ordner 2.8 die gleiche Ordnerstruktur wie in der vorherigen Version
  6. Im Win32-Ordner finden Sie einen Registry-Schlüssel mit dem Namen "Default/Standard".
  7. Bitte erstellen Sie nun den gleichen Schlüssel mit diesem Pfad in der Version 2.8.
  8. Starten Sie Ihren Client neu


Nun sollte officeatwork wie gewohnt funktionieren.